SHIPCONSTRUCTOR 2002 v1.71 now supports both NavisWorks 2.4 and 3.0

August, 2003

Albacore Research has announced ShipConstructor 2002 update 171 now supports both NavisWorks 2.4 and NavisWorks 3.0

Clients wishing to upgrade to version 3.0 can now do so safely as the ShipConstructor Flythrough can use either NavisWorks versions.

 Previous document Back